• Welcome to OnlyTech Forums
    An online community for the tech enthusiasts!
    Log in or Register

Seeking Help Issue with my PC

Ashok L

Member
Joined
15 Oct 2013
Messages
467
Reaction score
688
I have a Dell PC with 4 GB Ram, Dual core processor running in Windows 7 Ultimate...
For past 3 months, my pc is very slow and I am unable to do anything. When I checked the task manager I found a program svchost.exe consuming nearly 3.5 GB of Ram but CPU usage is only 2%. Only 2 to 3 MB of RAM is only free.

Please suggest a way to solve this issue
 

Zmint

Member
Joined
19 Jul 2018
Messages
211
Reaction score
300
I have a Dell PC with 4 GB Ram, Dual core processor running in Windows 7 Ultimate...
For past 3 months, my pc is very slow and I am unable to do anything. When I checked the task manager I found a program svchost.exe consuming nearly 3.5 GB of Ram but CPU usage is only 2%. Only 2 to 3 MB of RAM is only free.

Please suggest a way to solve this issue
Please follow this guide bro:

Thanks for sharing
Gone through the whole article and found this part of quite interesting ...
=====
".....While it’s possible that a virus has replaced the real Service Host with an executable of its own, it’s very unlikely. If you’d like to be sure, you can check out the underlying file location of the process. In Task Manager, right-click any Service Host process and choose the “Open File Location” option...."
=======
I had, quite a tough time troubleshooting many Pcs (Xp , Windows 7) to get rid of such Virus.
@Ashok L bro you should try to check your autostart entries
 
Last edited:

Ashok L

Member
Joined
15 Oct 2013
Messages
467
Reaction score
688
Thanks Bapun and Zmint bro. I will try this tomorrow. I think it might be a virus.
 

Top Bottom