Seeking Help Power button is taking too long to function in Poco M4 5G

  • Thread starter iDJ
  • Start date
  • Replies: Replies 4
  • Views: Views 717

iDJ

Elite
Contributor
Joined
23 Aug 2018
Messages
23,671
Solutions
4
Reaction score
29,163
Something odd is happening to my phone Poco M4 5G since yesterday. Ever since I put a new sim on my second sim slot. Power button is taking too long to come to screen from idle mode. Even double tapping isn't working. But when it works. When it works flawlessly. Otherwise after a long break. It takes time for screen to work. Today in the middle of the call. Screen went blank.

What could be the issue? Should I do a factory reset?
 
Issue is with the software,
Did you updated to latest Android/MIUI version?
  • If yes, you should wait for 6-7 days after which device will become stable.
  • If no, take it to service centre they'll install a stable software version.
Note : In any case you are visiting service centre take data back-up to save time.
 
Issue is with the software,
Did you updated to latest Android/MIUI version?
  • If yes, you should wait for 6-7 days after which device will become stable.
  • If no, take it to service centre they'll install a stable software version.
Note : In any case you are visiting service centre take data back-up to save time.
No, I haven't made any update recently.
 
Last edited:
Better visit service centre they'll surely help you. I guess you smartphone is under warranty. BTW could you please check default homepage in Chrome app, many users facing issue after Xiaomi changes default homepage in Chrome from google.com to
I reinserted the sim. It's working fine now. Only thing that still happens sometimes is screen goes blank sometimes in the middle of the call. Btw, I have disabled Chrome and most other Google apps.
 
Back
Top Bottom
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website. For the best site experience please disable your AdBlocker.

I've Disabled AdBlock