• Welcome to OnlyTech Forums
    An online community for the tech enthusiasts!
    Log in or Register

Jio Celebrations pack ruined my Postpaid 199. Pathetic Support from Nodal as well.

thisisjagan

Guru
Member
Joined
28 Jun 2016
Messages
1,250
Reaction score
1,500
I'm facing the issue again with my postpaid and wonder how speed test is still showing terrific bw, when my plan says speed is throttled.

Whats-App-Image-2018-11-28-at-3-17-34-PM-1.jpg
Whats-App-Image-2018-11-28-at-3-17-34-PM.jpg
It's time you change to Jio prepaid or Avoid postpaid.
 

KuLpreet Singh

Veteran
Member
Joined
9 Apr 2018
Messages
358
Reaction score
196
I too have issues with Jio Fi. I get slow speed (below 300 Kbps) but I get good speed when the sim is in mobile. I figured out that the issue is with Jio Fi. So, to fix the problem I turn on Jio-Fi reset it and use. I had to reset the device whenever I turn on to get better speed. I told CC also showed them speedtest comparison result. They told me you may get slower speed during network congestion.

BzPV5oZ.png
Check if ur connection is on 40 band and still speed is low,then there is issue with ur device. For me, it automatically connect to 40 band if i place it at a particular place in my room and i get speed upto 17Mbps
 

sumitroy

Senior Author, OnlyTech
Staff member
Moderator
Joined
27 Oct 2016
Messages
4,416
Reaction score
6,396
Check if ur connection is on 40 band and still speed is low,then there is issue with ur device. For me, it automatically connect to 40 band if i place it at a particular place in my room and i get speed upto 17Mbps
I too get band 40 most of the time. I feel the issue is with device because I get good speed immediately after resetting the device. Btw, it doesn't bother me anymore. I just reset the device every time I turn it on and it works just fine and Jio internet works too slow at evening irrespective of device.
 

KuLpreet Singh

Veteran
Member
Joined
9 Apr 2018
Messages
358
Reaction score
196
I too get band 40 most of the time. I feel the issue is with device because I get good speed immediately after resetting the device. Btw, it doesn't bother me anymore. I just reset the device every time I turn it on and it works just fine and Jio internet works too slow at evening irrespective of device.
I always get good speed if it is connected to 40 band. Maybe if it helps u jst find a sweet spot to place ur JioFi to get 40 band.
BTW,I inserted my battery wrong and might have damaged the charging point. Now my battery is not charging. Bt then i came to know that JioFi doesn’t need battery at all. Now using it while it is plugged with a 1V charger.
 
Last edited:
Top Bottom